a.isDirectory is not a function -> How to fix it

Hello,
I’m trying to init a custom block for my database but i get this following error whenever I launch the command line block init from any github repo.

Initializing block using https://github.com/xavdid/airtable-grouped-chart template
❌ Something failed! Cleaning up...
❌ Error: a.isDirectory is not a function

Do you have any idea how i can fix it please ?

Thanks in advance for your help
BR

Hey there - a couple questions for you:

What version of the blocks CLI are you running? block --version
What version of node are you running? node --version

Hi Taylor_Savage!!

Thx for your reply.
Here are the version :

  • Block version : 0.0.62
  • Node version : v8.5.0

Thanks for your help

I would try updating your node version - current long-term stable version is v14.

1 Like

Well done !! Thanks a lot @Taylor_Savage for your help.
Updating my node version fixed it

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.