Action required: dropping support for SDK versions < 0.0.40

Hello,

We are dropping support for older versions of the Blocks SDK. After May 29, 2020, blocks will need to use SDK version 0.0.40 or greater in order to run.

Here are the breaking changes from older SDK versions:

  • 0.0.31: renamed globalConfig APIs, removed models.generateGuid.
  • 0.0.32: removed localStorage and sessionStorage wrappers.
  • 0.0.33: settingsButton.isVisible is no longer settable.
  • 0.0.34: fieldTypes.LOOKUP renamed to fieldTypes.MULTIPLE_LOOKUP_VALUES.
  • 0.0.35: Toggle renamed to Switch, theme removed from Button and Switch, and Flow type definitions removed.
  • 0.0.41: BREAKING: useWatchable will now throw an error if the second argument keys is undefined.
  • 0.0.42: Field type and view type enums are now exported from '@airtable/blocks/models' as FieldType and ViewType (previously fieldTypes and viewTypes).

The full list of changes is available here.

To upgrade:

  • Edit the version of the @airtable/blocks package in your package.json file to be at least 0.0.40.
  • Update the installed version by running npm install .
  • Test your block by running block run .
  • Once you’ve updated the block to be compatible with the new version of the SDK, release your block by running block release .

Based on which blocks have been used in the past two weeks, we emailed all developers who will need to update their blocks to be compatible.

Thank you for participating in the custom blocks beta. I know breaking changes are annoying, but we will occasionally need to make them—especially during the beta—to let us release improvements more quickly. That said, we’ll continue to keep these disruptions to a minimum.

Please let us know if you have any questions.

6 Likes