Add item to grouped view

I am revisiting this topic from 2017 (see bottom for reference post)
I have two tables linked: Tasks, and Subtasks. Tasks also has a column called Area (single select).

When I group my data to the linked table Name Field (first column) I can add new entries via the “+”.

However, if I group by the linked table “Area” column, the “+” is not visible for adding new items.

Similarly, if I then add another grouping below Areas, called Tasks, I cannot see the “+” for adding new entries.

Does anyone know how I can group by the last two images, and retain the ability to quickly add entries?

Reference post of similar topic from 2017
Add data to “grouped” view - Ask the community - Airtable Community Forum

This is because {Area (from Task} is a Lookup-type field. When you group a view by a calculated field (which includes lookups, rollups, formulas, etc.) the “add new record” button is removed from the bottom of each group. This is because normally adding a new record directly to a group will fill in whatever field(s) the group is grouped by, but since Lookup fields cannot be edited this functionality cannot be replicated.

Thank you, that makes sense now that you explain it.

If there are any suggestions for how to group in this way please let me know. I tried to add a new function column to the active table (not the lookup table), with this formula “={area (from Task)}” but it yielded the same results.

Thank you, this forum is fantastic

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.