Airtable is converting WEBP images to PNG effectively making 50KB files into 700KB

Hello all,

I was trying to optimize a website and reducing the size of the images and I ran into a problem which is not occurring in other projects.

When converting the images to webp and uploading them to Airtable, Airtable is converting them back to PNG and feeding a 50KB file and making it 700KB. So I tried a few options and upon uploading smaller PNG’s in order not to have airtable convert, I noticed that a PNG file is 170KB yet, Airtable is still feeding it as a 700KB+ png file to my website. How is this possible? I have other projects using airtable and I can fetch webp files for starters with no issues. But with this project I don’t get webp, only PNG’s and they are also not the same size as the uploaded versions. I tried creating a new column and adding only webp files and the result is still the same.

Any suggestions on what I can do?

Thank you in advance.

The problem occurs when using the large thumbnail version. I assumed it would still be less than the original, but it is not.

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.