Airtable sending out survey but it doesn't work - permission restricted to specific domain ... huh?

Airtable asking me for feedback in a survey but the survey is not accessible (likely permissions issue in one of their customer support forms in Airtable). See screenshot.

I use outlook email so why Airtable wouldn’t want to hear my feedback to survey sent to my email.

OK, I received a new fixed link from Airtable and it works now. But the introduction message says “feedback … to help inform future improvements to Airtable” and the survey is actually about … how you use Airtable today with Zapier. So #1 the message doesn’t say it’s about Zapier (I don’t use Zapier with airtable because it has limitations in setup of triggers (see other people commented earlier in this forum) and #2 the survey is about how I use the integration today and what I do. I have expected the survey to say… what you like to do in the future and you can’t do (aren’t doing) today and why. #3 If the purpose of the survey is to improve Airtable own automations (that would be amazing, but it’s not clear if that’s the purpose), then why not include Integromat and Automate.io as well as Zapier. As most people here use Integromat you are making them wonder why you asking about Zapier. And if it’s about Zapier, well then, you need to talk about improvements. So as result of that I didn’t even finish the survey, it wasn’t what I was expecting.

Hi @itoldusoandso

Well, that’s very interesting.

It makes you wonder what the survey is really about.

I think a true survey should be more broader and more conclusive, at the same time.

Thanks for letting us know.

Mary Kay