API issue when filter is active in the GUI

#1

Hi everyone.

I have this issue:

I am requesting the API with asking for some field with no problems , I get my response ok, no prob.
Late, I do the exactly same request and I have no results… wait… what???
So, I’ve decided to check the data in the table, and oh! There’s an active filter in the GUI… so I’ve disabled, then I execute the API request and I get the result again.

Anyone already have the same problem? There’s any way or parameter that I can send in the request to avoid GUI filters?

Thanks in advance.

#2

Can you post more details that show the request you are making to Airtable? By default, when issuing GET requests for a table, Airtable will fetch all records. If you specify the “view” query parameter, then Airtable will only return records that are in that view which means any filters on that view will impact the records the API returns.

If you want all records from a table, then the following query is all you need:

curl -X GET \
  https://api.airtable.com/v0/{YOUR BASE ID}/{TABLE NAME} \
  -H 'Authorization: Bearer {YOUR API KEY}'
#3

Thanks a lot. I don’t knew about this view parameter, so I’ve removed it and only send the formula and everything works.

Thannnnnks a lot!