API Key Invalid

I am trying to build an external web app through either Pory or Softr, but my API key seems to have stopped working (I keep getting an invalid key error). Does any one know how to fix this? I’d hate to delete my current API key (I currently have some forms live on my site through Mini Extensions and it would break that connection (although it would be relatively easy to re-do…just not sure deleting/re-generating would really solve this problem - there’s no reason it should have stopped working in the first place). Any ideas? Thanks in advance!

Update: I deleted and re-generated; still doesn’t work. :pensive: As luck would have it, I ran into this problem right after working hours on Friday; I won’t get a response back from AT until at least Monday afternoon. Again, your help is appreciated.

1 Like

Aj,

You need to give us more data to help.

First - were/are the miniExtensions still functioning with the old or new key?

If they still work, the issue is your code, not your key. As such, you’ll need to expose the context of your API integration and perhaps the code, otherwise, all of us are flying blind.

1 Like

The key is working fine with Mini Extensions, therefore, I’m sure it’s not the key itself.

The API is being input into Softr and Pory so that data can be visualized in a different way to the public-at-large. There are sorting capabilities that extend the functionality beyond simply share viewing from the base itself (like I currently have it since this API integration is not working). These are “no code” integrations, so I don’t use code to integrate with these platforms. I’m not extremely knowledgeable on the complexities of API, but do know that the API key I currently have in the Airtable account section IS working with Mini Extensions, but NOT with these no-code web app builders (Softr and Pory, in my case). Beyond that, I don’t know why that integration is not working, what is causing a disconnection, but those app builders are showing that the API is “invalid.”

Maybe there’s something more I can look at deep in my AT account to answer your question, Bill, but again, I don’t immediately know what other information would be valuable to provide a solution to this issue. Of note: this is the first time I try a no-code app builder and I’ve had AT for over a year with no issues, but have never integrated the API key anywhere until very recently (first with Mini Extensions), now with these no-code app builders.

Does that provide a little more context, or help in some way? Please let me know if you need me to provide more information; I appreciate your reply!

If it’s not working with Pory or Softr, why are you not asking their tech support teams for help? You’ve already said that your API Key works just fine with MiniExtensions, so clearly the problem isn’t with the API key. It sounds like it’s a problem with Pory and Softr.

Well, he did, but this issue arose right when they closed for the weekend and he was seeking help here in case someone(s) were available like me and you who apparently do not have lives elsewhere. :wink:

2 Likes

If the API key works with miniExtensions, there’s nothing more to look at in Airtable - it’s simply an issue with those other two platforms as @ScottWorld made clear.

I would start by creating a brand new integration with one or both of those platforms because I have a hunch, their systems cache the API keys and maybe don’t refresh them but every 24 hours.

1 Like

Lol, this is true! :rofl::joy:

Oh, I didn’t see that he already contacted tech support after hours — but it looks like he contacted the wrong tech support. He said he contacted Airtable tech support, when he should be contacting those other companies. Since those other companies are just one-person or two-person companies, they might respond quickly.

This is a great hunch, and a great idea of something to try!

Agree. I think he thought this had to be an Airtable issue and has since learned it is not.

2 Likes

Thanks for your reply. I agree that I should have focused my attempts to contact tech support with those other companies - and, I did - but was just wondering if anyone had recommendations on what it could be in case there was a quick (however complex) fix I could perform on my end to make the API work with those companies. I’ve since communicated with Artur at Softr; we identified that, for whatever reason, there was an invisible space in the actual API key delivered via copy in Airtable. In other words, when you copy the API key in Airtable, and paste it into one of these other no-code platforms, the key was registering an invisible space. Initially, Artur thought it was a “key size” issue; we later learned it was not.

This is copied directly from my chat with Artur: “to be frank I did extend the key size but your key wasn’t too long. I suspect that when you copied there was a non visible char in the key. Our system checks that key starts with “key” and that it at least has 12 chars.”

I was able to gain access to Softr, but not Pory (I’m sure I’ll hear back on Monday from Pory to see what it could be on their end).

Thank you both for your comments and suggestions!

1 Like

Thank you for this suggestion. I even created new accounts on both of those platforms, deleted history/cookies, etc. for a whole week, restarted my computer, and prayed (a little), lol. That didn’t seem to work, and my other response indicates why. You’re the best Bill, thanks for your input!

Hi @Aj_Tavez,

I just tried and re-tried to open https://www.softr.io from my home and I just got

502 Bad Gateway

openresty/1.15.8.1

within 15 minutes, and trying softr.io, http://www.softr.io , https://softr.io , http://softr.io doesn’t returned anything else than returning https://www.softr.io/ in Search Bar and 502 Bad Gateway in ViewPort.

More about 502 on:
MDN 502 Bad Gateway

You will note that my CHROME (automatic updates ON) allows me to force http:// in place of https:// IF and only if http://web.site exists !

I’m in Europe, Belgium, between 7:30 am and 8 am GMT+1 , on MAC OS.

As it could depend on anything local I am not aware and I don’t have time to search now, I would try again from another place, ISP, computer and browser a little bit later, by remote-accessing my Job’s PC.

https://pory.io/ is ok !

I don’t know if it really helps but I think I should post that issue.

oLπ

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.