App localhost certificate error

Hello! When attempting to edit an app, I enter https://localhost:9000 into the Edit app dialog box, and I’m getting the following message:
Screen Shot 2021-01-20 at 6.27.50 AM

As well, I run into this screen when going directly to https://localhost:9000 in Chrome:

This did not occur previously. I’m not sure what happened but I don’t know what I’m supposed to enable. There doesn’t appear to be an allow-insecure-localhost flag when I go chrome://flags/#allow-insecure-localhost. Any idea what might be causing this?

1 Like

Hi all,

Erin with Airtable support here :wave:

I’ve already been in touch with Michael about this issue but wanted to post here as well in case others are running into the same thing. The allow-insecure-localhost flag was removed in the latest version of Chrome (v88), which caused this issue. Our team is working on a fix for this to enable custom app development in Chrome without this flag, and that fix will hopefully be released by early next week. In the meantime, we recommend using Safari or Firefox to develop custom apps, or downgrading Chrome to v87.

We’re very sorry for the inconvenience this caused! Thanks again for reporting this.

Here is a workaround that should work for Chrome in the meantime! More information on can also be found in that thread – looks like it is a bug that the flag was removed in Chrome v88.

2 Likes

That workaround allowed me to access an app on Airtable. Thank you.

JSKY, I also ran into a similar issue for both Safari and Firefox. I’ve included screenshots of both.

Safari - Screen Shot 2021-01-25 at 1.50.09 PM.png

Firefox - Screen Shot 2021-01-25 at 1.51.34 PM.png

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.