App Not Working on Android [RESOLVED]


Started about a week ago, app opens but none of the bases show up, and can’t log into Help and Support, but could log out.


Same problem. Mine just sits there and loads


I tried the following steps and it solved my problem. Maybe give it a try if you’re still in a weird state?

  1. From the Home screen, navigate to: Settings > Apps.
  2. Ensure All apps is selected. If needed, tap the Dropdown icon then select All apps.
  3. Locate the Airtable app and select it.
  4. Tap Storage.


Same problem for me. Just sits and spins when opening app. Tried clearing the apps cache per above and that didnt work. Anybody else have a way that fixed theirs?


I’m having the same issue. Tried clearing cache, force stopping the app, and logging out and logging back in. Still no luck.

Any solutions yet?


Still having the same issue. Hello, Airtable? Solutuon???


I’m having this same problem! Clear cache did not help.


For me uninstalling and clearing all left over cache and re-installing works pretty well.

With Regards,


A new version that mitigates some of these problems was just released!

closed #11


Since the last update (5 Dec), the app has become unusable. It takes 5-10 seconds to go from a record view, back to the record list.

If I don’t make any changes to the record, it works fine. But for even the smallest changes, it takes a long time for the app to go back to record list.

Is anyone else facing this issue?