Appending Row in Google Sheet, any numeric value will not populate

Automation is setup too append a row to a Google Sheet. All of the values (text, dates) will populate within the sheet row, except for the numerical score values when the automation is running. However, if I run test automation with the same record, the numeric value will populate into the column.

The scoring numeric values in AirTable are single select based on automated triggers to specify to a certain score. I have tried changing the column data format on the google sheet with no success. I have tried to change the triggers as well as adjusting the value lookup but still will not work unless I run a manual test. Any ideas on what I maybe missing?
Screen Shot 2022-06-08 at 12.06.43 PM

Hi Michael, I created a base to try to replicate the error you’re facing and could use more details to make it happen. Once I can make it happen reliably I’ll see what I can do to try to figure out a solution

Here’s what I’ve got so far:

  1. Trigger: When ‘Status’ single select field is the option ‘Send to Sheets’
  2. Action: Appends a row to sheets, where the value that’s being appended is a numeric value from a formula field with the following formula: {Value} + 3

What I do:

  1. Add a new record
  2. Set a number in the Value field
  3. Set the status to Send to Sheets

May I know what would I need to change to match your workflow to recreate the error?

Hi Adam, here is more information:

  • Trigger: When a Record enters a specific view (first screenshot)
  • Action: Append a new row to a Google Sheets (second screenshot)
    • All field values will append to the new row in the Google Sheet, except all of the numeric value fields will be “0” or “null”.
      (The numeric fields will populate if and when I run “Test Automation”, however if I check the “Run history” it will show that the numeric values are not appending to the column(s). (third screenshot - column number: 4, 5, 7, 9, 11)
      NOTE: The numeric values within those fields are set to “single select” for an attached form so the users input are only allowed to select one of those assigned numeric score values. The “Total Score” is a formula column to show the SUM of those valued columns.

C6E1577D-31F2-48C2-A9A8-143D576495E1_4_5005_c


Hi Michael, thanks for the details

Hmm, so I tried to mimick your system as much as possible and you can find my attempt here

  • Trigger: When a Record enters a specific view
  • Action: Appends a row to sheets, where the values that are being appended to the sheet are the following:
    • Value 1: Single select field option
    • Value 2: Single select field option
    • Value 3: Sum of Value 1 and Value 2

Screenshot 2022-06-09 at 9.43.23 PM
Screenshot 2022-06-09 at 9.43.30 PM

It appends the new row with all the values as expected in both “Test Automation” and running of the automation via a trigger normally.

Hmm, so users fill out the form where they select numeric options via the single select field, and once they submit the form, the newly created record enters the view, is that right?

Hi Adam,
Correct, users will fill out the review form, which will create a Record within the Table and then shows up to that view. There is one catch and I am wondering if this is the issue.

When a user submits the form, the form is designed in the screenshot. User will select one of the options that applies to the QA review on an individual. When the reviewer selects the choice, that point selection has an automation running when the form is submitted to update the numeric value field. I believe thinking more into this, that maybe the issue because when the form is submitted those values are not calculated into the numeric value fields until that automation completes.

Does that make sense?

Based on if that is true I may need to run the append to sheets with a delay some how.
022EE6B1-9ED1-4149-B92C-BB14767D43A8

Hey Michael, yeah that’s definitely something to investigate.

Maybe change the condition of the record appearing in the view to make sure that the number field the automation you mentioned is supposed to update is not empty?

That way the append row automation will only run after the that other automation’s been completed

We could also put the append row action as the last action of the automation you’re using to update the numeric field?

As an aside, may I know what issues you faced using a formula field to convert the select option into a number? Feels like we can just do that instead of using an automation, saving you an automation run

Hi Adam,
So talking this problem set through here with yourself, I pin pointed the problem and it is there are automations with another automation fed on that first one. So I adjusted the triggers to when a Record is updated and look at that specific value field to populate than update the sheets.

It worked several times after making this change and its good now.

Appreciate working with me and got me thinking a bit more outside of the box. Thanks again, Mike

2 Likes

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.