Attachments uploaded via API vanish within seconds

I am having a problem using Integromat to upload my email attachments to Airtable.
My process is to save attachments in Drive > Generate a direct download link (double checked that it works without requiring any login) > save all attachments in an array (multiple attachments) > upload the entire array to Airtable.

I also get the files uploaded to Airtable as seen on my Airtable base. But within seconds, all the files vanish. I am at the end of my wits trying to figure out the problem. My email is a Google Workspace account, and I am currently trying out the Pro plan of Airtable.

Also, the first few records uploaded using Zapier are still there. But Integromat uploads keep on disappearing.

Please help!

Hi @Sales_Asian_Drive_Sh, and welcome to the community!

Yep - this “bug” has been discussed …

And most recently, this thread.

Despite the many claims [by Airtable] that this issue has been fixed, there is a preponderance of evidence to the contrary.

1 Like

@Jason, In another thread, you mentioned that this issue was resolved. Could you check this issue again and see where it keeps failing?
This issue is pretty recurring, as Bill mentions.

I am having the exact same issues, it has been driving me nuts. I don’t have anything to add solution wise, but hope to hear of a fix!

My workflow is also from google drive to airtable via integromat and I have checked the regular issues (privacy of the files/folders) and everything appears to be working correctly.

I have also tried substituting google drive with Dropbox and whilst the attachments are not being deleted they are not viewable within airtable (they can be downloaded from airtable and viewed).

I know that people are having these problems. However, I am continually NOT having this issue, so I’m wondering if this problem is only affecting certain accounts?? Very bizarre situation.

I just tried this again on my end right now… I successfully uploaded 25 files to Airtable from Google Drive via Integromat, including large .mp4 movie files and large .jpg images.

Everyone has their Integromat scenarios setup like this, yes?

Scenario overview:

Get a Share Link:

Create New Record:

Tried again just now. It worked. I guess it is an intermittent issue with Airtable.

This is not a valid assessment. Successfully uploading 25 files is anecdotal data; see my first referenced assessment in this thread - I tested with thousands of files to isolate the likelihood that this is related to the Airtable API. And the size or type of the attachment is irrelevant in all tests where failures occurred.


If you look back at all the threads, you will see a pattern of on- and off-again outcomes. It will work fine for many weeks and for hundreds – perhaps thousands – of processes, and then it will begin to skip a few, and sometimes many dozens for a single table.

For a long time I thought Integromat and Zapier were impervious to this issue, but this is not the case; various instances have emerged when even these tools have exhibited failures that appear to align with this observed unreliability.

1 Like

You’re right.
I’ve had to resort to use two different Integrations to solve this issue: One to save the mail (without Attachments) to Airtable making sure there is a column for saving the message ID. And the second to run the Attachment import using the message ID if a checkbox is checked. That increases the manual work, but allows me to repeat the import in case attachment fails to show up in Airtable.

I’m sorry you’re having an issue! Resolving issues and bugs is best done directly with our support team, so please reach out (via our in-app help menu) and our team can work with you to help get things resolved.

I don’t think this is the best approach, but certainly, support needs to be in the loop.

By suggesting this one user mount the challenge alone with support requires him/her to be apprised in all facets of this ongoing issue that is well-documented by many users and across at least 8 threads.

In my view, there is enough evidence to suggest Airtable has a dysfunction and a product manager should be all over this acting as the liaison with support. Sort’a like a class-action lawsuit - there are many parties being injured by this issue and no single support ticket or person can adequately represent the interests of all users to (a) verifying the failures and (b) testing the possible remedy.

Just sayin’ …


This is the understatement of the year.

1 Like

Looks like my vanishing PDFs are back… All was working as expected for about 2 weeks and now I am having the same issues, it is extremely frustrating.

I have reached out to Support @Jason, however I agree with Bill, this must be sorted - it is clearly a bug with the API as it works perfectly for periods of times and then has issues.

As predicted and experienced by countless users including @JN_tp.

1 Like

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.