Automated Gmail - fields not populating

I have an automation set to send an email (via gmail) when a record is created (when a purchase is completed - this is one of the tables).

This pulls from a number of fields across different tables, via look ups.

All the fields populate fine in the preview, or when generating a test, but when an actual purchase is made and the automation is triggered for real, none of them populate in the actual email. I had to re-run the automation (and then it worked fine). The email is sent ok (and to the correct address), but in the body none of the variable fields are populated, and just appear empty.

Is the email being triggered too soon? Ie, the fields haven’t actually populated in the record itself before the email is sent? Should I add some kind of delay step before the email is triggered (can’t see a way of doing that)? What else could be going on?

image

The trigger “when a record is created” will not work for your needs, because it triggers when the record is actually created, meaning that it triggers while the record is still blank. You will need to choose a different trigger.

Thanks!
I created a filtered view which is only populated once all the fields are completed, and used this as a trigger. Seems to work

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.