Automation Email - URL link broken

We have a URL field where we insert long Google Doc url’s. We then have an email automation working but when the email arrives, the link is broken - most of it shows as a hyperlink but the last 5-10 characters are plain text.

Is this a character count limitation within Airtable Automations or is there anything we can do to fix it?

Thank you!

Are there any special characters in the url, such as underscore characters?

When Airtable automations send out emails, they parse markdown text formatting in a strange way that can break links.

Yes, thank you! I just noticed that the break happens at the first underscore…

Does anyone know if this will be fixed?

This is two of the many reasons we avoid using Airtable automation to dispatch emails. Instead, we push all dispatch processes to a webhook in Workspaces where we can conceal the lengthy URLs as embedded HTML.

Lacking that, we have used a URL shortner on the Google URLs applied in Airtable using a simple script automation. This makes it possible to eliminate these massive URLs while making the direct emails (a) cleaner and (b) actually work.

Try this formula to escape the underscores:

SUBSTITUTE({Original Url}, "_", "\_")

I thought about this approach and imagined that it would require an unescape process at some point or the URLs would be broken. Would the email clients all naturally unescape these urls?

I only used the escaped urls when sending the url via an Airtable email automation so that the url is correct when the email arrives at the client. This thread has more info.

1 Like

@kuovonne Thank you! The formula worked and fixed the email URL issue :smile: