Automation fails intermittently since "conditional actions" were implemented!

Hello,

I have a problem with an automation that works intermittently. I tried to follow the errors one by one to try to understand why sometimes it works and sometimes not!
First records are created in a table (A) from a “Typeform” form which also fills in a “Parent record ID”.
Then the automation must update records on another table (B) found from the “parent ID”.
There is no problem to create the records on Table (A).
But the automatism which is supposed to update the table (B) does not always work… it drives me crazy!
An automation that is incorrectly configured never works!
An automation may occasionally fail for x reasons.
But when it only works 2 out of 3 times… it’s weird.

Note that these issues arose after the new “conditional actions” were implemented last week…not sure if it’s related.
Have any of you had issues like this?



Thank you for your help.

Your screenshot says that it received “invalid inputs”. If you click on that “Fields” line, I’m assuming that it may show you which fields failed and possibly what inputs it received.

Hi Scott,
yes I know… I’ve seen that, but it does not show the invalid input.
You can see attached one automation that succeeded an another one that failed… non difference !
The most important is that the automation founds the “Record ID” to update, and in both cases it is found!
So???


Not sure, it doesn’t seem to indicate where the problem is. Maybe it has something to do with that multi-select field… do all of those values already exist in your table B to begin with?

Hi Scott, I’m sure that this multi-select is exactly the same in both tables, I checked it many times.
Also, when automation fails, I execute the same process from the beginning (from the typeform step) with exactly the same data, and you know what ? I didn’t fail !
Strange, isn’t it ?

Very bizarre. It’s hard to troubleshoot since your data is starting in an external app, but who knows what the issue could be. An alternative would be to use a middleman automation tool like Integromat to grab the data from Typeform and then send it to Airtable from there. And you could even use Integromat to run your other automations as well (you’d have to recreate them in Integromat first). The reason I suggest this is because Integromat has very detailed error reporting, so it will tell you EXACTLY what the problem is.

@Issam_Chaouch Could you please share a screenshot showing the configuration of the “Update record” action?

Hi Justin,
Thanks for the interest.
The screenshot is here.

Hi Scott,
I am seriously thinking to jump to the Integromat solution.

@Issam_Chaouch Thanks. Nothing is leaping out at me. Looking back at your original screenshots, it looks like some file attachments are coming from a temporary space that Typeform has provided. This is a long shot, but it’s possible that the file isn’t lasting long enough to get saved by Airtable. Maybe Typeform is deleting the temporary file while Airtable is trying to save it, though that’s probably not the case because I’ve seen cases in the past like that, and the file just disappears. There’s no error message.

It’s worth giving Integromat a try to see if you’ve have better luck. :person_shrugging:

Hi Justin,
I also believed in this eventuality, but I noticed that the automation can fail with both attachments of 8MB and others of 200KB, and vice versa with the automations that work?
Now I’m trying to see if the choice of the browser in the first step (typeform) can be the problem? Indeed, the last part of the URL of the form that the candidate filled in contains the Record_ID of Airtable… maybe from one browser to another a small string of characters is added and therefore the Record_ID is corrupted and Airtable does not find the related record in table A!
What do you think about that?

Anything is possible, but IMO that scenario is highly unlikely. My gut feeling is that browser developers go out of their way to ensure that data passing through their product does so without being modified.

The only way that I could offer more specific guidance is to directly look at the base in question and run several tests, which means taking this on as a client project. I don’t think that it would take long, though, so the cost wouldn’t be very great. If that’s of interest to you, ping me directly and we’ll set up a meeting.

Hi Justin,

Thanks for the proposal and ideas…
but look at that experience (screenshot video attached).
this is made on two automations that are exactly the same. I mean that when it has failed once, I took the same typeform Link and I fill the form myself with exactly the same data, and of course for the same record_ID!
Then I took the record_ID that should be recognized by the automation, and just made a filter on the referred table to see to which record is related to.
For the automation that succeeded, I find the record in the table, but I cannot find-it using EXACTLY the record-ID but copied from the failing automation ???
How can you explain that?
Strange, isn’t it?

https://youtu.be/ED2cRYaeiiE

Yes, that’s definitely strange, but my gut says that there’s a reasonable explanation behind it. Is there another automation that deletes records based on certain criteria? Are users manually deleting records at any point? There are so many factors about this setup that your video doesn’t clarify. It’s only showing a few details related to the end result. In order to troubleshoot, we need to start at the beginning of the process and examine the setup of each step in the automation, carefully tracking all data points from start to finish.

Hi all,

I share with you all the trick that I found to solve this problem.
As I noticed, following the experience explained on the video of my last post, that the problem seems to come from the “Record_ID” which seems to undergo an addition of spaces in the string.
So I added a column that takes the “Record_ID” with the ‘TRIM()’ function which removes the spaces before and after.
And I changed the reference to look for on table B which therefore becomes this Trimmed “Record_ID”.
Since I made this change, the automation did not fail anymore…

That’s all folks !

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.