Automation Stopped Working, Test runs fine but in practice won't run

I had an automation that when I created a new record of a participant’s information into a time point of our survey (ex. baseline, 3 month, 6 month, etc.) that it would find records with the same participant ID and link them together.

I have separate tables for each time point, and the initial automation I had working was “when a record is created in “baseline”, find records in “Master” where participant screener ID is screening ID from baseline, update records in Master with Baseline”. This automation was working perfectly fine for two weeks. I tried to enter some data yesterday and all of a sudden it’s stopped working. I get a message of “invalid filters” for the “find records step” for some reason now. I haven’t changed anything about the automation itself or the tables involved in this automation. When I test the automation, it finds the records perfectly fine but when I run the automation in practice, it says invalid filters. I’m not sure what’s wrong or what to do. Pictures included below of what this broken step looks like now.


It may actually be the initial “when a record is created” step that isn’t working. I’ve continued messing around with the automation and got it to work one time of previously entered data but when I enter a new participant is when the automation fails to run correctly. Screenshots below of the automation when it works vs. when it doesn’t. I’m not sure when a record that is already in the table works perfectly in this step but newly created records are making it go haywire…


The thing to note about that trigger is that it’s quite literal: it will fire the instant that the new record is created. That means that if you make a new record in a grid view and then start entering data into fields, Airtable has already sent the record to the automation before you began editing. As far as the automation is concerned, the fields are empty at the time the record was created, so things aren’t going to behave as you expect. This trigger is great for cases where new records are made from a form or via Airtable’s API—where the record and its data are made at the same time—but it doesn’t work well for manual entry.

Unfortunately there isn’t a built-in way to tell Airtable to “pause” and wait for you enter data before acting on a newly-created record using that trigger, so you’ll need to pick a different trigger. Perhaps you could use “When record matches conditions”, checking for certain fields to be populated in specific ways before the automation triggers. The thing to note here is that this will only fire on changes that occur after the automation is activated. Existing records that meet the conditions won’t trigger it, but new records that match the conditions for the first time will, as will existing records that change from not meeting the conditions to meeting them, even if they had met them previously.

2 Likes

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.