Automations and lookup field issues

I’m setting an automation to send a slack message using a lookup field (formatted as string).
The automation doesn’t get the value from this lookup field. I get an error message saying “This property cannot be used right now” Has anyone hit the same issue or has something to add to help?

Try creating a calculation field based on the lookup then use the calculation field instead of the lookup

1 Like

Yes, what @Steve_Haysom said is correct. Unfortunately, lookup fields aren’t supported by automations, which is not documented anywhere by Airtable. You are required to create a formula field that equals your lookup field.

@Steve_Haysom Sorry for the current limitation here - lookup fields aren’t currently supported in automations as noted in this related support article. As mentioned, we do plan to support lookup fields in the future.

1 Like

Thanks Jason. i just tried an automation myself and the test keeps failing, saying that there is no input even when there is, I’m using an email address calculated from a lookup using the arrayjoin formula. If I type an email in the field by hand then the test passes, but that’s not much use though. It picks up calculated start and end dates for a google calendar invite, but not the attendees.

@Steve_Haysom Could you try running a new test for the automation trigger? Then, try another test for the action again.

I’ve found situations where ARRAYJOIN() doesn’t work as expected with the value from a lookup field. A more reliable way of converting a lookup’s array into a string is to concatenate it with an empty string:

{Lookup Field Name} & ""

I’ve tried doing this for a date and time field but the test still fails. I’m trying to send a google calendar invite, maybe you can have a look: Google Calendar automation - cannot parse date and time!

Thanks for the info, but I tried again and it seems that the available values aren’t appearing in the test data. I gave up and tried creating another trigger which just sends an email, but that also was not working as the send email action would not allow me to run a test with the update record trigger even though I had entered values for all the fields. I was thinking that I would send an email with the record id to a google apps script and do things there, but I would need a create and update trigger to do it properly.

I’m not sure that I understand the problems you’re having. Could you share some screenshots showing the flow of your automation?

It seems to working now. The run test button was appearing grayed out, now it’s working ok and the emails are being sent. thanks for the help.

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.