Batch Update Block - Images are greyed out

The batch update block does not seem to allow selection of image fields for update.
I plan to import 2000 records into a table.

THEN I need to import 2000 images whose names match via the record ID as primary photos.
THEN I need to import 2000 more images whose names match via the record ID as secondary photos. etc

Cannot see where this may be possible in AirTable

Welcome to the community, @Max_Schramm! :smiley: It looks like you might have a misconception of how the Batch Update block operates. It’s not a batch import block, if that’s what you’re thinking. It only makes certain kinds of basic batch changes: setting values of cells, clearing cells, etc.

I think what you want to accomplish could be done with the help of external integration services like Zapier or Integromat. Can you share more info about these 2000 records you’re importing? Are they in a CSV file? Where are the images (both primary and secondary) currently stored?

Thanks for the prompt and thorough response!
They are museum object records in csv format c text and memo fields.
Pictures are in a folder c matching inventory codes e.g. DJ-1234 is the object DJ-1234-A, DJ-1234-B are the images related to it.
Shudder at thought of manually adding image by image.

@Max_Schramm, I agree. No human should ever have to do the same thing more than 7 times. :wink:

I build automated data (and video/imagery) systems all the time. If you have budget to make this 2,000+ upload happen overnight, give me a shout.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.