Blank records created when doing a bulk upload from excel

I’m trying to bulk upload records from an excel file. the columns match. but whenever i finalize the upload, airtable creates my new records AND it also creates a boatload of blank records. this is particularly irritating because i am doing an initial upload of many records into a table that has automations that create records in a different table whenever records are created in the current table. so now i have to delete the blank records from the one table, and go delete the blank records from the other table too.

is there a way to set limits on what airtable imports from excel? i assumed it would stop importing when there wasn’t data in the cells. but this is not the case.

If you haven’t found anything while looking through the Excel import options, then such a feature doesn’t exist. Unfortunately the empty lines at the bottom of an Excel spreadsheet are all included when saving the file and importing it somewhere else. The only way to not import them is to delete them from the original file first.

Thanks for responding. So, when you import from excel, you are forced to import a certain minimum number of records?

i guess that is fine. it would be a helpful thing for airtable to clarify in their instructions on importing.

i could delete rows. but i’m deleting empty rows in an excel worksheet. they don’t really go away. they just get replaced by new empty rows.

hmm. maybe i will try setting print limits. maybe if i set those up, then airtable will only import the rows within my print limits? worth a shot. i’ll report back.

if anyone else has a suggestion, i would welcome it. this seems like a really weird bug.

Export your records from Excel to a CSV file, and use the CSV Import Extension instead.

  • If you still get the blank records, then the problem is with your data.

  • If you don’t get the blank records anymore, then the problem is with Airtable’s Excel Importing tool, and you should report it ASAP to support@airtable.com.

That did it. i couldn’t see any data in any other fields. but i was working with a file someone else prepared for me. when i tried the csv import extension, there were still the blank records. so i deleted about 1800 rows (just to be safe). and voila! no more blank records being imported.

thanks to you both!

1 Like

No. I was saying that Airtable is going to import whatever you give it, including the empty rows. If you give Airtable a file with 50 filled rows and 50 unfilled rows, it’s going to import all 100 rows. However, if you open the original file, delete the 50 empty rows, then save and import to Airtable, you won’t get any empty records in Airtable.

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.