Calendar color field not showing up

Hi
I have a table with a lookup from another table in a grid view in which the result is Brown. When I go to the calendar view to select the field for the color, it’s not in the list of options.



Thank you!

Yeah, Airtable’s lookup fields will convert your single-select field to an array, so you’ll have to manually create all of your coloring criteria from scratch.

You may want to bring up this issue to support@airtable.com, so hopefully they can improve this behavior in the future.

As @ScottWorld said, there’s no default way to do this.

However, there is a workaround that, while a little clunky, definitely will accomplish what you’re looking for. It requires setting up an automation that watches for when a record is linked, and then copies the linked color to a single-select field in the same table as the desired calendar view.

Here’s a quick walkthrough I recorded on setting this up for your base.

Hope this is helpful,
Paul

2 Likes

Hi Paul
Thank you so much for taking your time to make the video. I am new to AT but I will give it a try tonight.

1 Like

This is a fantastic workaround! Sorry I didn’t mention this earlier, @Russ_Keitel!

Oh no problem. I just appreciate the the incredible support from the people here

2 Likes

Hah, that’s brilliant

1 Like

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.