Calendar invites automation

I have an automation that creates a google calendar entry from my AirTable calendar.

What I can’t figure out is how to automate sending a calendar invite to the other attendees. I have fields in my AirTable calendar with their names and email addresses and added their email addresses to the Attendee field in the “Google Calendar: Create Event” automation but the recipients are not receiving an invite. What am I missing?

I just noticed this that says:“Don’t send event notifications” but I don’t see a way to change it.

Hello,

I believe the reason why your attendees are not receiving an invite is that the field you are inputting as “attendee” is not an “email” field in your automation. I have run into the same problem. It worked perfectly fine when I used their “email” field. I have had to change the logic of the tables, and now the email field is a “lookup” field. And that’s when the automation stopped working :confused:

It will work for a lookup field, as long as you drill down into the lookup field and choose “Value” when choosing that field for your automation action.

If it’s still not working, then be sure to re-run your trigger test and then re-run your action test.

1 Like

Hello Scott! Thank you, this has worked perfectly fine.
I am having another issue with my “create G Calendar event” automation I hope you can help me with.

I am using the following formula field in the “Start time” field: DATETIME_PARSE( DATETIME_FORMAT( SET_TIMEZONE( {Interview Start Time (CET)}, 'Europe/Berlin' ), 'M/D/Y h:mm A'), 'M/D/YYYY h:mm A' ) and this one fot the “End time”: DATEADD({(AUT) Interview Start time }, 30,'minutes')

My Interview Start Time field follows the Central European Timezone (i.e November 5th at 9:00 am CET). I have booked this slot as if I was a candidate and the automation created an event in my calendar at 11:00 am CET, so 2 hours later.

Assuming the formula is causing this time glitch, I fail to understand where it is incorrect.

@Irene_Navarro I would check your field to see if you have selected the GMT time zone option. If so, that might be causing the problem in Google Calendar.

p.s. For a really deep dive into time zones, you may want to check out my time zone training video & sample base: