Calendar with Calculated Date/Time doesn't show time correctly


My base uses a calculated field to create a date and time. In a calendar view, the date works fine, but the time is not utilized. Events are all shown as taking place at 12 regardless of the time shown in the calc field. How come? Can I fix it?


Hi Thom, that sounds like it could be a bug. Can you email with a few details about how your calculated field is configured (what formula, formatting, and time zone options you’re using) so that we can look into what’s happening here?


I had the same issue with all appointments showing at 12am, but was able to resolve it… I checked the formatting of the calculated date/time field, and changed from 12 hour to 24 hour under “Time Format” and then the appointments started showing at the correct times on the calendar.


Thanks. I’ll give that a try!