Can't "find records" using autonumber field

Suppose I am trying to grab some records from table 2 using a set of linked records from table 1 with an automation so I can show a list or gallery of these records in an email.

For whatever reason no matter how I do it, Airtable will not let me use an autonumber field to do this. I’ve tried it both as a primary and non-primary field, I’ve tried using a formula, I even tried creating a formula that gets the record ID and then seeing if Find Records could find that (which resulted in an “unkown error”).

I don’t know why any of this is the case when its essentially performing a sort of janky database join. I’d appreciate any suggestions for workarounds.

If you are curious what exactly I need this for: I have a series of equipment reservations. I want to list the equipment details in an email detailing the reservation. The trigger needs to be a form on the reservation table.

Solution found. I changed my primary field to the RECORD_ID() formula in my reservations table. Then I search for linked records in my equipment table containing the record ID of my reservation. Kinda confusing and weird but works.
image

1 Like

Hi,

Anyway, just to clarify. I think that’s because you are trying to use number in a string function “Contains”. You should create formula field to convert it to string,
‘’&{Reservation ID} or CONCATENATE({Reservation ID}) to put it in filter.
If test fails, instead of “Insert”, do “continue”-"uppercase (or lowercase, no matter for number)

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.