Can't get 'Limit record selection to a view' to 'limit'

I’m setting up a base to among other things track articles aligned with specific research topics. The end goal is a record of articles/papers/research already reviewed and deemed relevant.

Two tables:

  1. Reading log: web-clipped articles with four views; “Articles – Read and relevant” relates to my question.

  1. My research topics: If working correctly, only articles that are both read and relevant should appear here. The “Related reading” field is linked to “Reading log” with view limited to “Articles – Read and relevant.”

Problems I’m encountering:

  • For Topic A: A linked record appears even though not read and no selection made for relevant yes/no field.

  • For Topic B: An article that was read but marked not relevant (“Research suggests the blue economy could bolster global food security”) is still appearing as a linked record.

Have I configured this incorrectly? Thanks for any tips!

The important thing to note about limiting record selection to a view is that the limiting behavior isn’t a “live” feature. This has two implications:

First, if records are already linked when you turn that feature on, but they don’t appear in the specified view tied to the limit, they won’t be taken away. The limiting feature only works when adding new linked records to that field, which is why the wording says “Limit record selection to a view” (emphasis mine). For example, the “Research suggests…” article isn’t in the limiting view. If you remove that link, then try to add it again, it won’t appear as an option. You can’t select it as a new choice, but if it was there prior to the limit setting being activated, it still stays.

Second, the limiting feature is only honored in the table where the limit is set. In your base, you’ve set the limit on the {Related reading} field in the [My research topics] table, which means that it will only apply when adding links from that table. Going back to the example above, if you added the link to Topic B on the “Research suggests…” record in [Reading log], Airtable didn’t look to see if it matches the limit set in [My research topics] before allowing it to be added. It just adds it.

1 Like

@Justin_Barrett Thank you for this beautiful breakdown. Some of this I know, applied before, but totally blanked on. I was trying to force my use case on the feature.

Seems I’ll have to sacrifice linked records if I want the Related Reading field to be “live” as you described, and not a selection of articles associated with topics to choose from. I can isolate the read and relevant articles in the Reading Log table via a formula I’ve used before, then lookup the output in the My Research Topics table. It’s not a tidy solution because eventually, that will result in a huge wall of comma-separated text.

I tried a couple of formulas in the Mock fx field and neither worked. Any idea what the hiccup might be? I appreciate all the help!

Option 1

IF(AND(🧾 Read?,AND({Relevant?}="✔ yes"))(Title),BLANK())

Option 2

IF((🧾 Read?),AND({Relevant?}="✔ yes"))(Title),BLANK())

Option 3

IF(AND({🧾 Read?},AND({Relevant?})="✔ yes")),(Title),BLANK())

There are a couple things amiss with the structure of the formulas, mainly relating to the AND() structure. Also, you can leave out BLANK() at the very end. If that third part of the IF() function is omitted, Airtable will automatically insert the proper equivalent to BLANK() based on the formula’s other output. Here’s a corrected version that should work:

IF(AND({🧾 Read?}, {Relevant?}="✔ yes"), Title)
1 Like

@Justin_Barrett thanks for that! I was over-stuffing :slight_smile:

…which reminds me, I should probably get off this thing and turn my attention to Thanksgiving. :wink:

you should @Justin_Barrett. Enjoy.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.