Choosing the time zone used for Date and Time functions

I’m not sure if this helps but when using time formulas, if you clicking on the formatting tab you can uncheck use " Use the same time zone (GMT) for all collaborators ". This will display your local time.

4 Likes

That did it for me. Thanks Chinara.

The problem is that this is not using my local time and I need to set my account to use Central (Chicago) time. It is 2 hours off. This is a bizarre design flaw. When integrate to an external calendar App my info is not accurate. ??

1 Like

We should really need to at least know what time zone the time in a column was created… I’ve been traveling a bunch and it’s next to impossible to figure out if the time value has changed or not… kind of forces you to use a Single line text/String to track time instead of the time field type, since you can’t really trust it’s showing you the right value.

For example, if you set an agenda (9am registration opens) and then you travel to another time zone, it magically says the registration opens at 8am… but in reality, you always want it to be at 9… it shouldn’t depend on where you are. Yikes! And as someone said, using GMT isn’t really helpful either :frowning:

3 Likes

Looking through this thread and it’s been going on for years… it’s now 2019. When is this going to be fixed? Having to create a formula field to try to adjust isn’t a solution. I can hardly figure this out and my co-workers I’m setting up definitely can’t. I have this linked to send an email when something we need to do starts on that day but it’s sending it to us the day before that because GMT is so many hours ahead. How can I fix this? I need it to be in PST.

1 Like

Can you describe more about the system you’re using for this email notification? My guess is that you’re tying in to Zapier or Integromat, in which case you’ve got one additional place that you need to set your time. I don’t know for sure about Zapier, but Integromat user settings include an option for specifying which time zone should be used as the default for time-based operations (like triggering a scenario to run). To find that setting, click on your user button at the bottom left when logged in, choose Profile, then select the Time Zone Settings tab.

EDIT: Found a similar setting in Zapier, at the bottom of the profile page.

Hi, I am using zapier and the time zone is already set to Los Angeles.

1 Like

I am having a similar problem. I am loading an Airtable base from Zapier (timezone is set to Anchorage). It appears that Airtable is resetting the time/timezone when ever the record gets created. I can verify Airtable is changing the date/timezone because the Zap sends a text with twilio as the next step in the Zap and the time is correct. Date and Time seem pretty easy, but it is actually an extremely difficult problem to implement. I agree, it is time (haha) for Airtable to step up and tackle this problem, it will be 2020 soon and this thread has been going on since January 2016…

The problem with DATETIME_FORMAT() is it changes the data type from date to string. I haven’t been able to find a function that converts a string into a date data type.

1 Like

See DATETIME_PARSE(). It uses the same format specifiers as DATETIME_FORMAT() but converts a string to a datetime value.

The wide range of input and output formats supported allow for all sorts of interesting datetime hacks. Two of my favorites can be found in this reply.

1 Like

I changed my Airtable timezone setting to “Use the same time zone (GMT) for all collaborators” and know AT is using the correct date the zap is delivering, the only problem is AT thinks it is GMT, but it is actually Anchorage time. I could change my zap system time to GMT, but the transaction time I am loading into my base would have to be converted to GMT from Anchorage, where and how would i do that? This is a lot of mental gymnastics… It sure would be nice if you could set the timezone in the base preferences…

1 Like

Look at the second example in this reply. You can use a format specifier to extract a value you can then feed directly back into DATEADD() in order to restate your local time as GMT. I agree, it gets confusing when working with an integration timestamp. In your case, I think I’d load it into a non-GMT field, restate it into GMT, and use that value in any calculations…

1 Like

@Sarah_Smith1 Does any of the above help in your situation? I’ve been too busy lately to dive in for a deeper look.

Just to clarify, I’m not an Airtable employee, so I can’t speak to how/if the team is addressing this issue.

Stiiiiil nothing? It’s the year 2247 and Airtable hasn’t fixed their timezone bug.

Is this still the best solution? (over 4 years later)

DOES ANYONE WHO WORKS AT AIRTABLE KNOW ABOUT THIS ISSUE?

We can’t ask people to convert a date to GMT when they enter it. That makes no sense.

And we can’t have people look at an event date in their own timezone, bc that makes maintenance of event times virtually impossible.

And this makes the calendar sharing virtually useless, since when we import the calendar into google calendar, etc, it shows all the wrong dates.

AIRTABLE PEOPLE, PLEASE HELP.

4 Likes

Hi,
the workaround I’ve found is to:

  1. create a new field (say DATE OK);
  2. Make it a formula field
  3. Use this kind of formula (this one substract 4 hours to GMT which seems to be the default Timezone in Aritable): DATEADD(Date,-4,‘hours’)
  4. Adjust the format at will.
    Hope this help!
    Cheer
    s

I’ve created a sample base & accompanying training video to solve the dilemma of working with multiple different time zones in Airtable.

You can click on the link above to be taken to my solution in the Airtable Universe, or you can go to my post for this topic here: