Copy concatenated text without quotes at beginning & end of text - TextSoap / MacOS

The manual way to copy text described above doesn’t work for fields Long Text Fields with Rich Text Formatting because if there is a rich text formatting in the copied text, doing Copy and Past (at least on MacOS) will add line breaks after every block of text and you end up with double or tripple line breaks. I don’t care about preserving formatting, just don’t want to end up with line breaks. So I am avoiding quotes and end up with linebreaks doesn’t help.

This is a minor annoyance with copying text out of Airtable. Unless you do the extra steps to only copy selected text, copying the entire cell will add (mostly) unwanted quotes marks at the beginning and end of the copied text. Before you can use in another appliation, it’s almost always neessary to strip the quotes away from the text.
There are a few tools on Windows but on Mac there are less options due to sandboxing etc, however, there are a few that work. If you are on MacOS, there is TextMate is one, WordService another, or Cleantext, but if you are looking for a convenient way 1-button to press, you can try TextSoap.

It allows you to record a short key e.g. cmd+D and add a task to strip the quotes. You need to create a custom macro in TextSoap app.
It doesn’t have a task to strip quotes for whole text block (I didn’t figore it out quickly enough) so I picked the “remove prefix” and “remove suffix” from lines.
Now, to copy text, I mark the whole cell of the field, press CMD+C and then CMD+D.
TextSoap will automatically past the copied text when pressing CMD+D.
If you want to simplify it, you can add the copy task to the commend in TextSoap.
Now it’s enough to press CMD+D, the field is copied and processed, ready to be pasted in your application.
The only issue I find is I couldn’t figure out how to disable auto-past in the TextSoap application. It’s not a problem because Airtable doesn’t allow pasting text when the cell is not opened, so AIrtable will show a toast notofication saying you can’t past text. That’s not a problem.
If anybody finds a way to disable to auto-past, please suggest.

You may need to change asignment of the shorcut CMD+D if you want to use this one. This shortcut is by default assigned in TextSoap (see menu) and you can re-assign the menu item to something else (System Preferences / Keyboard / Shortcuts. Then you have the CMD+D combination available for TextSoap macro.

UPDATE

I found even a better tool for that - Keyboard Maestro for MacOS

Works like charm and now I have automated also window switching. So just pressing CMD+D will copy the Airtable cell, strip the quotes, switch the window back to where I was and past the text.

image_2022-01-17_235513

The question of copying was discussed a few times in the past…

and here…

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.