Copy down returned wrong record

I tried to copy a linked record cell down, but it returned a wong record.

I have a table of events, the name of the event (1st column of the table) will be reused every 3 years (same name on a different date). I have another table of event attendance. I tried to copy an event (a linked record) to other rows which are different attendees of the same event. The record returned in other rows are not the one I copied, it is another event with the same name, but it was 3 years ago.

Video Capture for reference

I copied the event down, but it shows a wrong date. The date is a lookup of the event. Does copying linked record processed with the recordID or the first column? Is it a bug or I have done it wrong?

Thanks for your help!

Airtable will pick the “first” record (created) with the name you specified when you type, fill handle, or paste like that. I wouldn’t call it a bug, though it may not be desired behavior.

The way you get around this is by actually giving your records unique names. That is typically best practice anyway.

Thanks Kamille for your reply! Well, I have done this task a lot of time in the same table before and the result is corrent. I do have different records using the same name before. The fact is the behavior of how Airtable handle this task has changed, or this is not the expected behaviour.

Conversely, this has always been the behavior for me. Is it possible that names were nearly identical but had an extra space or something?