Create filter to clear whole view

Hello.
I’m trying to create a zap with zapier that will trigger when there is a new airtable record in the view, and then it will post it to my social media. The problem is that I want to import the csv to the table instead of doing it all manually, but I can only import my file to the view when I create a new table, but if I’ll just create a new table with the csv already imported and then turn on the zap, it won’t post all of the imported content. So I want to create a filter that will clear the view, then turn the zap on, and then I’ll remove the filter. So I was suggested to create a filter something like this:

one of the rows in the table: contains: eg: skdjfhksdjhfkjsdhfk

But I didn’t understand how this will work and what should I write instead of skdjfhksdjhfkjsdhfk and instead of the example row in the table because he said I should write skdjfhksdjhfkjsdhfk but he sent a screenshot with kajdfhkjadfkjahfs So I don’t know which one I should use, or if I should use a different one.
Thank you in advance.

Welcome to the Airtable community!

There are a couple of issues here.

  1. To create a view that filters out all records, include a condition that none of the records will match. In the example you provide skdjfhksdjhfkjsdhfk and kajdfhkjadfkjahfs are just random strings of characters that none of your records will have. The exact string of characters doesn’t matter as long as it doesn’t appear in your data.

  2. You state when you are importing your CSV file, it creates a new table. If you have a pro subscription, you can import a CSV file to an existing table with the CSV import app. If you have a free account, it is also possible to import data to an existing table via copy/paste.

Firstly thank you for your quick answer.

  1. By appear in my data you mean that the exact whole string of characters appears in one of the rows, I got it right ?
  2. But I can’t copy paste the whole thing because it will all enter in to one row, I need to copy row row.

I will try using the filter, and will come back to you.

Well this is really weird. I created the filters and the whole table was cleared, I then created the zap and activated it, then removed the filters, and the table was filled again, but when I ran the zap it couldn’t pick up any new records in the table.
How can this be ?

Is you trigger for new records or new records in a view?

If you are using Zapier, also keep in mind that the zap will trigger only the first time the record enters the view. If a record falls out of a view and then re-enters it, the Zapier zap will not trigger a second time.

  1. My zap is triggered for new records in a specific table in a specific base ( in the app and event tab the event is: New Record, but in the customize record tab I need to choose the base and table for the records to be pulled from. )
  2. So you say that even if I create the table and the filter and only then create the zap, so that the table was already clear when I firstly created the zap, it still won’t be triggered when I remove the filter ? If so do you have any other solution that will work ?

You need to use a “New Record in View” trigger, not just “New Record”. The “New Record” trigger only fires when a record is created–if the record exists (in any view) before you turn on the Zap, it won’t trigger the zap.

So if I’ll change the event to “New Record In View” when I’ll remove the filter, the zap will work ?

Yes, if you remove the records from the view, convert the zap to a “New Record in View” zap, it should work the first time that the records enter the view.

yes, thank you !! I did this and it worked !! For some reason it posted only seven posts on twitter, but posted almost all in facebook, I’m still having some problems with the images in facebook, but this is already for facebook support. Thank you so much for your time and support.

1 Like