"Created Time" Automation

I have a “Created Time” field which I am trying to use to trigger automations. When I test the trigger, it says it was successful but is only finding 1 record when there should be many. I’ve tried setting different conditions, but no matter how I set them, the automation is not capturing the correct records. Am I missing something?

An automation only processes one record at a time. If there are multiple records that each match the necessary conditions, they will each trigger a separate run of the same automation; e.g. five triggering records will run the automation five times. Also be aware that once an automation is active, it will only run on new triggers that match the conditions. Existing records that matched the conditions at the time of activation won’t trigger it unless the trigger mechanism can be “reset” somehow; i.e. by changing a formula calculation.

If you want to only run the automation one time and have it operate on a collection of records, then you’ll need to design a trigger that either exists separate from the records that you want to process (i.e. on a different table), or only triggers on one record in that collection (i.e. using a formula to generate the triggering output only on a single record, usually a record with a specific name that will never be deleted). In either case, the rest of the records would be retrieved and processed elsewhere in the automation (e.g. via the “Find records” action, or perhaps a script action).

I’ve got a setup that uses the former design, with the trigger happening in a completely separate table. It’s designed to trigger the automation on a regular schedule (once daily at midnight), and a script action finds the necessary records to process. This way I only have one automation run per day, but I’m processing potentially dozens of records.

Does that make sense?

1 Like

This was helpful in understanding how AirTable actions work. Thank you.

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.