Date and Time field in an automation

Hello all! I have a mentor/ mentee booking system I’ve set up through Airtable. However Mentors are looking to set-up standing availability. To do this I’ve added a Weekly or Monthly to the form.

I’m trying to use automation to trigger when they are selected and create new records (DATEADD 7 days ,etc), which simply need their email and the new times (a Week out, for 12 weeks, or a month out for the same). However I can’t get the automation to accept a formula (whether directly in the automation, or pulling from a new column) for the Date and Time field. It either says cannot convert the string to time, or when I have it correctly in date time then it tests successfully but leaves the date and time field blank in the new record.

Any ideas on workarounds? I was thinking maybe Zapier, but it would be very clunky and many steps. Not sure if there is a way to use a scripting block here.

Welcome to the community, @Brian_Keenan!

Automation actions don’t support formulas being typed directly into the action, so you would need to do one of the following:

  1. Set your date field to the value of a formula field that results in date. If you’re getting the error message that you specified above, it means that your formula field is resulting in text instead of a date.

  2. Run a script that sets the date field.

  3. Use an external automation tool, like Integromat or Zapier. You mentioned Zapier, but note that Zapier is typically not recommended, because it has many limitations (both Airtable limitations & platform limitations) when it is compared to Integromat. (Note that I am a Registered Integromat Partner, and that link contains my personal referral code.)

Hope this helps!

1 Like

Thank you Scott for the helpful reply!

Option 1 is what I have been trying, but even when it is correctly a date time, while the automation will run with no error, the field is appearing blank in the new record. I’m not sure why it’s not accepting it.

Option 2 I’m learning but not proficient enough with scripts at the moment

If it’s showing up empty, then it sounds like you might be pulling the date & time formula from the new record instead of pulling it from the triggering record.

Thank you for the help! The fix ended up being - I needed to re-run the test on the automations trigger, since I had updated the new formula field post the initial test. Once I did this, the new action worked.

1 Like