Date field inserts wrong time


#1

Hi, I have a column of type Date. “Include a time field” is checked. But I noticed that this inserts the wrong time. It inserts the time 1 hour earlier than the system time. How can I fix this so that the correct time is inserted?


#2

Do you have the “Use the same time zone…” option checked?
image

That would make a difference.

Other than that, it could be a bug.


#3

No. It wasn’t checked. I checked it and tried but same thing happened. This may be related to Daylight Savings Time. Here in Turkey we don’t switch anymore. Do you think it has something to do with this?

Also I guess there is no Settings page to set things like this.

Thanks for your help.


#4

If this was a recent change, and Turkey does not yet have a dedicated timezone in ISO or web standard parlance, then that could very well be the case.