Date & Time Read Incorrectly for Formulas

I have a Date/Time field that feeds into a formula field to pull the date from it. It used to work perfectly well, now that I have added the time option to it as well though there is an issue with it sorted dates wrong.

As an example I have a task that is listed with the date 1/19/2021 7:00pm but when I put it into the formula it reads it as 01/20/2021. If I change the time to 1/19/2021 7:00am it reads it as 01/19/2021.

It does read the Date/Time correctly in Calendar view.

Is there anything I can do to ensure it reads the Date/Time field correctly for the formula? It is important for grouping reasons.

The formula I am currently using is: IF({Due On}=BLANK(), “N/A”, DATETIME_FORMAT({Due On}, ‘L’))

Welcome to the community, @Tashina_O!

This is a tricky one, because this is a time zone issue.

The very first thing to check is to make sure that your GMT time zone setting is set the same for both fields.

If that doesn’t work, you might need to dive into some time zone formulas.

I’ve also created a training video & sample base, which serve as a deep dive into time zones:

1 Like

This worked perfectly! I never even thought time zones would have been an issue as it’s just me accessing this in the same timezone I created everything in. Thank you so much for your swift response and the simple to follow tutorial.

1 Like

Glad I could help! :slight_smile:

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.