Date / Time sync from Airtable to Google Cal

Having issues with time entry from Airtable base, changing when syncing to my Google Calendar. I’ve tried several different approaches for the sync (Sharing Airtable Calendar View, Zapier and Automation: sending an event). Each approach properly syncs the day, but the time from my Airtable base table is always 5 hours off from the synced event in my Google Calendar. Example: 7PM in my Airtable base table, synced to 2PM on my Google Calendar. This 5 hour difference leads me to believe it’s a time zone setting. I’m American/Chicago time zone.

Airtable Date Column Settings: Date Format: Friendly; Time Format: 12 hour; I’ve turned on “Use the same time zone (GMT) for all collaborators”

Any suggestions what setting I’ve overlooked?

User Level: Free Account

I’d been struggling with this one too. But I solved it.
Here is what I did.
I opened Google Calendar Settings and went to Time Zone. Chose GMT as the Primary. Clicked “Display secondary time zone”, then set the Secondary time zone to my time zone.


But, once I swapped the label of GMT and EST It seems to read correctly on the Calendar.


Now it looks correct and the times on the events show up properly too.