DATEADD Function Broken [Solved]


#1

Hello,
DateAdd appears to be adding days incorrectly.
To replicate:
Col1: date field (date only, no time)
Col2: DATEADD(Col1,1,‘d’)
Format Col2 to show date only, no time.

In this case, Col2 shows the same date as Col1. When time is shown, behavior seems to be normal.

See photos attached:


#2

Works well for me, using the exact same formula:

I’ve tested all Date Formats in the Date field. Maybe your result is related with the time zones?


#3

The time zone was the crux of the issue. Looks like you have to tick the box that says “use the same time zone (GMT) for all collaborators” in the formatting tab. I had it unchecked.

I am not sure I understand that feature, but I will remember to keep that box checked.

Thanks for a speedy response.