DATETIME_PARSE does not recognize my datestring!

Hi there! I’ve been using DATETIME_PARSE for some time now to convert outputs (datetime strings) from formulas into dates with format but now DATETIME_PARSE is not working anymore. I don´t know if Airtable has made any updates around this function recently?

Just to give a further context, I use DATETIME_PARSE to convert datetime strings (with this format ‘DD/MM/YYYY’) resulting from a formula into Dates with a format that Airtable can read in order to compare them with other dates (these dates have the Airtable format). DATETIME_PARSE used to convert them into comparable dates but now the formula says #ERROR! all the time.

If any of you know about any updates Airtable made around this formula or instead knows how I could solve this problema please let me know!! I’ve already tried 1.000 different things :frowning:

Thank you for your time!!!

I’m having the same issue here, same string DD/MM/YYYY. Result is #ERROR! and it just doesn’t make sense. Did you find any other solution?

If your date string is in any other format besides the U.S. date string format of MM/DD/YYYY, then you need to specifically tell the DATETIME_PARSE function what format you are using.

So, your formula would need to look something like this:

DATETIME_PARSE('31/12/2020','DD/MM/YYYY')

or

DATETIME_PARSE({Date_Field},'DD/MM/YYYY')

Hi Scott!

We tried. It doesn’t work, even specifying the format it returns “error”. Is like the function is ‘broken’ somehow.

I hope someone in the Airtable team can check this out soon. I need to make some calendars!

What is your formula?

Sorry Scott! I think it’s about how I constructed the tables, timezone probably in conflict somehow.
Still, sometimes the datetime parse function won’t “parse” the string as a date.

Since I redo a lot of the tables, I’ll be alert on catching an example for you. Now I don’t have any.
Thanks!!