Disabling currency conversion to local currency

Hi community,

I have managed to create a synced table from a Salesforce “Revenue report” that I am going to combine with data from other sources. Part of that report is the revenue number that is listed in USD, but when I look at the synced data in Airtable, it shows up in the local currency, in my case NOK. Somewhere in the sync, the data is converted through a factor or source that I have no control over to the local currency. It is also missing three digits…

For example; a 10 000,00 USD deal shows up as NOK 85.00, which should be NOK 85 000,00 (but according to Nordea (A Norwegian bank) it should be NOK 83 690).

As we are usually talking about our deals in USD anyway, I was wondering if there is a possibility to disable this conversion from happening?