Disappearing issue using form

Hi,

I just faced the problem quite a few times. I made my form and put all the necessary questionnaires for my users’ interview and when I reopen the form it seemed a few of the questions are missing from the main form. I was wondering what a misbehave it is and facing it quite a few times make me crazy about it. Would be appreciated if you look at it asap and solve it for convenience.

Thanks,
Ahsan Habib Imrose
Founder, AgroChain

Welcome to the community, @Ahsan_Habib_Imrose! :smiley: I haven’t seen this behavior before. Did you have Airtable open in more than one browser tab? Or perhaps open in both a browser tab and in the standalone desktop app? I ran into an issue the other day in the latter category. Most of the time I only use the desktop app, but something I was doing opened a base in the browser, and I found things getting messed up because they weren’t staying in sync. That’s the only situation that I can think of that would cause the kind of behavior that you described.