Error at Zapier Automation

Hello,

I’m trying to create an automation in Zapier where when a record is updated in a Google Sheets spreadsheet, automatically a specific record in Airtable is also updated.
For that, I followed the steps on this page: https://support.airtable.com/hc/en-us/articles/218151657-Using-Zapier-s-Multi-Step-Zaps-to-find-and-update-records

Everything worked perfectly using a test table that I created in Airtable, but when I try to use the table that I really want to update, I’m getting the following error message:

“The app returned” Unknown field name: “fldGbqW7NsISXtzKT” “.”

It is as if the “Record” field that I am using as a reference to update the record was not being found.

Could you please help me?

I think what is happening here is that the Zap is trying to find a field in your “real” table that does not exist. Everything in Airtable has an ID - records, tables, views and fields (and probably a lot more besides). We don’t normally see the IDs, but I’m pretty sure that when you set up a Zap for a field name “ABC123” Zapier doesn’t use the field name but gets the field ID and sends data to this (via the AT API). This is handy because if you change the field name the Zap doesn’t care and doesn’t break.

So my guess is that you’ve switched tables from test to “real” but haven’t switched fields. “ABC123” in test is a different field to “ABC123” in real (even though they have the same name). What I think you should do is refresh the field selection in the Zap (under the table selection if I remember correctly), then choose the field again. This will set up the real field and it should work.

2 Likes

Thank you @JonathanBowen
It really worked.

I only deleted the step that updates and recreated it.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.