Failed update to API call in Data Fetcher app: "Can't Update Field: invalid field config"

Hello, completely new to Airtable and fairly new on dealing with APIs. I was super excited that I was able to get an API connection to work and successfully pull the data I needed a few weeks ago. Today I went back because I forgot to include two fields in the original pull of the data. I amended my Body JSON query to include these two new fields and when I use the “Open Field Mapping” button in the Data Fetcher app everything actually looks fine (it’s pulling in the new fields). But, when I run the query, I receive the following warning with the yellow exclamation:

Can’t update field: invalid field config. Failed schema validation: symbol is not included in the .(type=number).options schema

Because I’m fairly new both APIs and Airtable, is someone able to give me a “laymans” explanation of what I can search for to troubleshoot this warning. Interestingly, while I see Airtable successfully pulling in the two new fields (and with the right data populating), when I go to the actual table and view I am populating with the data, the fields are there but none of the data is populated.

Any threads of help very much appreciated!

Welcome to the community, @Justin_Eppley!

It sounds like you’re trying to bring in symbols into a number field, which isn’t allowed.

I’m assuming that your symbol is the dollar sign, in which case you could switch your number field to a currency field.

Although a better catch-all solution would be to just switch your field to a text field, and then you can covert it later to a more appropriate field type.

1 Like

@ScottWorld Thanks for the welcome and for the solution. I took the advice of just using the catch-all but only after starting from scratch in a new table. The thinking is that I’ll just change the field types then in the program I’m actually bringing the data into after Airtable so hopefully I won’t get an error when I go back. Seems like I shouldn’t based on the logic. Thanks again!

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.