Failure to run blocks-cli after install

Hi all!

I’ve installed the blocks-cli through node, but when I try and run it (for example the command to set up a hello world block, but also just running ‘block’ on its own) I get the following error:

/usr/local/lib/node_modules/@airtable/blocks-cli/node_modules/update-notifier/index.js:74
			(async () => {
			       ^
SyntaxError: Unexpected token (
    at createScript (vm.js:56:10)
    at Object.runInThisContext (vm.js:97:10)
    at Module._compile (module.js:542:28)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/local/lib/node_modules/@airtable/blocks-cli/transpiled/src/run_block_cli_async.js:215:454)

Could anyone shed some light on how I might be able to resolve this? Thank you!

Tom

Sooo turns out if your node version is 6 (!) then things don’t work quite as they should. I updated to 14.7, reinstalled and all is looking much healthier.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.