"File was removed" after being added via API

I’m not sure to understand what’s happening.

I’m pushing files as attachments and receive the response as expected.
For example, I get the following for the file I uploaded:

  "id": "attIuYUqNG4YvfUvz",
  "url": "https://<...>/doc.jpg",
  "filename": "doc.jpg"

But then when I look at the history,

Any tip on why this may be happening? :thinking:

Hi @gabin_desserprit, and welcome to the community!

Yes. This Airtable bug is probably what’s happening.

It’s been deeply discussed …

And most recently, this thread .

Despite the many claims [by Airtable] that this issue has been fixed, there is a preponderance of evidence to the contrary.

Hi @Bill.French! I kinda felt like I was falling the same hole too that the other discussions too.

But I in fact didn’t. I was trying to upload files that were uploaded in JotForm via their forms. The thing is, they by default have weird set up on their endpoint that was making the upload fail (also Airtable wasn’t complaining about it). I had to untick “Don’t ask for auth on downloading files” in JotForm, also it wasn’t really requesting any auth as I was able to access the files from anywhere (not authed).

Anyway, this mistery is solved for my case. :ok_hand:

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.