Formula bug? IF Statement not working


#1

Hi there,

I’m fighting with quite a simple Formula.

IF({DealType}="LIMIT_BUY",0-{Price},{Price})

DealType is a single select field that can contain LIMIT_SELL and LIMIT_BUY as an option. I think it’s clear that I want to have the Price (which is another field containing decimal number values as a negative number in this new formula field.

Problem is that even if the DealType is LIMIT_BUY the IF Statement doesn’t fire the first value, but always the second. I tried renaming fields, copying the values over to be sure to have no strange characters in there, and all that stuff. I can’t see why this Conditional doesn’t get true.

Maybe I’m just blind and overlooking things. What did I miss?

Cheers


#2

I tried recreating this on a table with the same field names and it works for me. What type of field is the {Price} field? Is your single option field definitely the exact text you’ve got there – “LIMIT_BUY”?


#3

The Price is a number field with highest amount of decimals. The single select field definitely has this text. I copied it over, also tried the text of the other option. Definitey doesn’t work.

Somehow this base or table seems to be broken. I already saw errors that “{Price}” is not a valid field name even though I slected it from the suggestions. I had to close and reopen the base and then it worked again. Weird.


#4

Try moving that first record down a bit and see if it’s always the first record, or if it’s a coincidence and only that specific record.

If you want, you can make me an edit only user so I can troubleshoot. But it would take some trust. I don’t know how to prove myself trustworthy.