Formula help: 3 different columns

Hi! We’re trying to figure out what formula is to be set in place for this scenario:

We have three forms, all connected to autopopulate on Airtable.
Column A = Form A
Column B = Form B
Column C = Form C

Basically, what we have a column with the formula that determines what form a client has filled out based on what Column has been autopopulated - let’s call it Column X.

What we want to happen is = if Column A has been populated, Column X says “Form A”; if Column B is populated, Column X says “Form B” and so on.

Only one column will be populated at a time per row (ex. Row 1 Column A populated, Row 2 Column B etc), so I hope that makes the formula creation easier.

Thank you in advance!

Hi Ribbleton. Here you go…

IF(OR({Column A}, {Column B}, {Column C}),
   IF({Column A}, 'Form A', IF({Column B}, 'Form B', 'Form C')),
   'Missing data')

I’ve included a check to make sure at least one of the columns has data, but you can get rid of it.

Good luck.

Hi there! Thanks for responding.
The formula isn’t working, unfortunately.

Here are our exact column names:

Funnel (this is where the column formula will be in place)

Feel - Traditional (C) (if Form A has been filled out, this gets filled in)
Study Option (TJ) (if Form B has been filled out, this gets filled in)
Mentoring Option (TJ 8.0) (if Form C has been filled out, this gets filled in)

Here’s how I’m doing the formula right now:

IF(OR({Feel - Traditional (C)}, {Study Option (TJ)}, {Mentoring Option (TJ 8.0)}),
IF({Feel - Traditional (C)}, 'Clinic’ 7.0, IF({Study Option (TJ)}, ‘VSL’, ‘8.0’)),
‘Missing data’)

Here’s a screenshot of the error:

Thanks for your help!

@Ribbleton Look very carefully at the formula field, and you’ll notice that some of the quotes are straight (perfectly vertical) while others are styled (slightly slanted). Airtable formulas won’t work with styled quotes. Change them to straight quotes by retyping them.

There also appears to be a missing comma between the “Clinic” string and the 7.0 that immediately follows it.

1 Like

You need to place that 7.0 inside the single quotes next to Clinic - 'Clinic 7.0'. And as Justin said, make sure your single quotes are straight.

Thank you all! It worked :slight_smile:

1 Like

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.