Google Calendar automation - cannot parse date and time!

Has anyone tried out the new google calendar automation?

I have two tables: timeslots and reservations. For the start and end date of the calendar invite, I use the lookup to get the times from the timeslots table. Unfortunately the automation doesn’t support lookup fields yet so I made a formula instead (it’s just the field name of the lookup).

When I test the automation, it fails! It cannot parse the start and end time. Any workarounds to this?

Screen Shot 2020-09-15 at 9.43.39 AM Screen Shot 2020-09-15 at 9.41.23 AM Screen Shot 2020-09-15 at 9.41.07 AM

1 Like

Try {Start Date} & "" to force the formula to return a string, not an array.

1 Like

Hi Kamille! I’ve changed the formula to what you suggested and ran the test again. Unfortunately it still doesn’t work. Any other ideas?

Try: DATETIME_PARSE({Start Date}&"")

I’ve tried this and it doesn’t work either.

I have tried with a normal date field and it doesn’t work as well? Strange! I made sure to put dates in the future and that all records had these fields filled out

Screen Shot 2020-09-15 at 11.47.33 AM

!

I don’t know what to to tell you. The automation runs for me using regular date fields or formula fields formatted as dates. Try: testing the original trigger again, then testing the calendar action step; deleting the calendar step and adding a fresh one; starting a new automation from scratch.

If I’m reading that correctly, your trigger is the linked Google calendar, not Airtable. Something is amiss with what’s coming from the calendar side of things. Your field isn’t named “Start Date and Time”, so the field isn’t the problem. Could you share a screenshot of the full trigger setup?

Thanks Kamille, what a simple solution! I should have done this earlier. I created a new automation and followed {Start Date} & “” as the formula

Justin, here is my full trigger setup:

Got 'em with the old “turn it off, turn it back on approach”

2 Likes

Hahaha yep, the oldest play in the book!

1 Like

When in doubt, “jiggle the wires”! Y’all, I was on a flight once that was delayed (of course) out of Chicago. The captain came over the speaker system, told us there was an “electrical” problem, and that he was basically going to “reboot” the airplane. Yep. Then we taxied down the runway and took off… AHHHHH!

Now, related, I just wanted to say I appreciate this post. I’m in the midst of doing the same sync/automation, and am so thankful to this community for being a step ahead of me!

1 Like

Hi,
I have made
Tables:

I tried using google calendar automation.
The problem i am facing is that start time is picked up different and if the meeting time is 5pm the google calendar via automation is 8-9 pm .
Don’t know why. Checked all parsed info.
Please help

Here is a sample base and training video on working with time zones in Airtable:

It did not work.
Tried Set_TIMEZONE(), new time zone is set. but when connect it to Google calendar via Zapier or via Automation it picks up 5:30 hrs more.
I noticed that GMT +5:30 is my time zone
See the difference in the Zapier screenshot

Is the GMT Time Zone option turned on for your date field? If not, it’s possible that the automations always send times to Google as GMT.

1 Like

oh my god. you won’t believe what happened just now.
now i know the problem.
I had VPN on. and due to which Airtable was booking at different time. When i Did DATETIME_FORMAT(SET_TIMEZONE({Start time}, ‘Asia/Kolkata’), ‘MM/DD/YYYY h:mm’)

I could see the difference in time.

i was wondering my Airtable is picking some other time zone. Later I realised its VPN.

Plus the GMT button "
Use the same time zone (GMT) for all collaborators" .
Now when disabled button with VPN its working fine.

Sorted.
Thanks

3 Likes

Hey, I’m having the same issue: I can’t create an event based on dates in my table.
I need to create an event based on formula born date-times, and that didn’t work; but even now testing with normal date columnes (with hardcoded values) didn’t work as well.
It encounters an error:
< Unable to parse datetime: “” >
But there is definitely data in those columns.
Here is an illustration.

1 Like

Welcome to the community, @Tomer_Eldor! :smiley: Were those dates added before or after you tested the trigger step? When building and testing an automation, the data collected when testing the trigger is passed to the next step, and that step’s test is passed to the step after it, and so on. In other words, if you tested the trigger with empty date fields, and then added the dates before adding and testing your Google Calendar step, that will explain the error. You’ll need to re-run the test on the trigger (and other steps leading up to the Google Calendar step) before testing that step will work.

1 Like