Google Maps API error


I am trying to connect the maps block and am getting an error using the API key, pretty new to this set - any help?

I am attempting to use the Google Maps Block.

Bug behavior:
Google Maps block slowly (1 request / second according to Google’s Activity Dashboard) fetches Geocache Data and fills the column in airtable. However, the map displays the greyed out overlay “For development purposes only” and asks if I want to overwrite the Geocache data each time I expand the block to view more.

It appears Google has limited this type of integration with third party services like Airtable. What is Airtable’s official stance on this bug?

I would post a screenshot but community .airtable. com says I am not allowed.


I see this exact same behaviour. I’ve tried things like making sure billing is up to date, project profile is correctly completed and so-on.

I spoke with support but haven’t yet followed up. They suggest the problem is that I have not yet set up billing with Google Cloud API. I checked and I have not, in fact, attached a credit card.

If you have time, @Nick_Jackson, try to set up billing in Google and let us know if that solves the problem.

This forum won’t let me share a link… but its under Billing in the left-hand menu on the Google API dashboard site.

Ah, that solved it!

For anyone else stuck here, I’d added a billing source but it wasn’t correctly attached to the project. Going to the Billing option in the menu lets you fix this.

Does anyone know if you can limit the map calls to the free allocation if you enter a payment method? I’m doing this for free to help with the COVID-19 supplies shortage, but I can’t afford a several hundred dollar bill for too many calls.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.