Google Sheets & Excel import to new table hanging/failing every time!?

I’m trying to import a large spreadsheet to a new table.

The spreadsheet has about 8.5k rows and about 30+ columns.

I’ve tried to import it via both the Google Sheets and Excel importer and in both occasions (on several attempts) it shows the correct data/sheet to import but on clicking ‘Import’, it just hangs on ‘Importing your data…’ with a spinning circle (and a greyed out background). I’ve even left it for 24hrs and it’s still on the same page. I’ve cancelled and started again several times and the same thing keeps happening and there’s never any evidence of even a partial import (it never even creates the new table).

Can someone please advise only I’m not a enterprise client (I’m a Pro Client) so they’ve advised I contact the forum.

Thank you

Stephen

PS I’m importing in from the Mac Desktop Client not via the Web Client.

Those are brand new importing options — and Airtable doesn’t pay much attention to non-web versions of Airtable — so there are probably bugs with either the import or the desktop client.

You may want to try using the web client, and you may also want to try exporting your data as a CSV file & then using the CSV app to import.

Most of all, though, you should email support@airtable.com to let them know about the problem you’re having.

Many thanks for the tip Scott. I’ll give it a go.

PS So I’m not asking to much of Air Table in respect of importing such a large spreadsheet?

Maybe. In the past, the limit for importing CSV files was 2,500 rows. They seem to have increased the limit to 25,000 rows (according to their support article for the CSV app), but who knows. The world of Airtable is filled with inconsistencies and bizarre issues like this.

Okay. Worth knowing. Thanks again.

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.