Grid View Summary > Allow to define decimal precision for "Count" summary

When you group rows in a grid view, you can select how each column will be summarized.
When selecting the “Average” or “Median” summary, the format of the summary is the same as the format of the lines being summarized. If my column is a “Count” from rows of another table, then they are an integer, and my summary is an integer too.
This is not helpful in my case, as my real average is 2.54. I don’t want to see 3.
I worked around it by creating a formula column that is equal to the Count column, setting the format as decimal, and then using it for my summary.