Help with IF percentage formula for negative values

Hello AT Community

I’ve got a formula partially working but I’m having some difficulty tweaking it to just the right look.

Looking for numbers in the SAL field that result as a negative to show the emoji - so far so good. How do I make positive numbers in the ‘test’ field show as a percentage with only two numbers behind the decimal and with proper rounding up?

Thanks in advance for your brilliance!

@Lisa_Morales

You can click formatting tab as in the following

It might not be possible the way I recommended because for formatting to work the result of formula should be number. In your case result is emoji or number.

Neal

@Lisa_Morales

Check out the following base

It manipulates decimal number before and after decimal point.
Please note that this is initial version .
You need to check and modify formulas so that it works for all the possible numbers in your base.

  • Copy base
  • check formulas
  • Build formulas for your base
  • Test it
  • Let me know if you need help

Neal

Thanks so much Neal, I don’t see where I can copy the base. I don’t get the formatting option because of the formula. I think the base was shared as view only, as I can’t see any of the formulas or copy. Appreciate your help.

@Lisa_Morales
Sorry Lisa,

Following link will get you as editor in the base .

Please let me know if you encounter any problems.

Thanks,
Neal

@Lisa_Morales
Lisa,
I was also able to change permission to you as editor.
No need to click above link to the base.
You are all set and you should be able to have copy base link as well as you should be able to see formulas.

Other users can click the following link to base and they will get editor access.
It will also have copy-base link to copy base.


Thanks,
Neal

Thanks so much Neal, unfortunately when I click the formula, formula 2, formula 3, field 8, and field 9 I can’t see the customize field type option which would show me the formula you made. Would it be possible to change my permission to ‘creator’ so I can see the formula when I select the dropdown for each of these fields in the customize field type option?

21%20PM

@Lisa_Morales

I have set you up as creator.

Other alternative for looking at formulas is to copy/duplicate base .

Neal

Thanks Neal, for some reason I didn’t have the option to copy/duplicate the base, not sure why? I’ll look again, grateful for your help!

Neal, you’re amazing! I have reviewed and but unfortunately, I’m still confused. I looked at my initial post and adjusted the wording I’m hoping it makes better sense?

@Lisa_Morales

I have created field called “Lisa” and it uses single formula instead of using multiple formulas.It will help you to use formula without need of understanding dependent formulas.
Name of field I am using is called “decimal”. You need to replace “decimal” with your fieldname in your base.

Neal

Thanks again Neal, I still can’t get it to work right, I’m using the SAL field in the formula where you used the decimal field.

13%20AM

@Lisa_Morales

Formula expects field to be Decimal instead of currency.

At present your SAL is of type currency. Change its formatting to be Decimal.
i.e. Customize field SAL formatting to be
Decimal(1.0) with precision 1.00

Neal

Thanks, Neal, unfortunately, that is not an option. I have to keep the SAL field as a dollar amount.

This is what I was able to do as a workaround. I can’t have the emoticon face populate for negative numbers in the SAL field - which what I was looking for. But until there is a better solution, I’ll have to stick with this:

48%20PM

I am grateful for your support in all of this!

@Lisa_Morales

Try the following

  • Create field SALCOPY of type formula. Formula will be SAL% and format it as decimal with precision 1.00
  • Create field SalEmoji and its formula will be the formula with emoji but use fieldname SALCOPY in that formula
  • SALEmoji field will have data as per your need.
  • SALCOPY can be hidden afterwards.

Neal