Help with Updating Record automation

Hi, guys! I’m trying to create an automation. Every time I enter a record matching specified conditions, I need an automation to update that same record, inserting values in two other fields.
I did the following steps:
Trigger: when a record enters a view
Action 1: find records where labels is ImportantUrgent
Action 2: update record from the Table Tasks, where RecordID is Records (Step 2: find records - List of Record Id, Field Importance is Important and Urgency is Urgent.
Yesterday, when I inserted only one record, that automation worked just fine.
Today, when I inserted another record, the automation failed.
See the screenshots below.
Could you please help me fix this?
[EDIT] I’ve tried several combinations. Keep receiving the same error message.

The “Find records” action is the cause of your problem, and it’s actually not needed to make this work. Long story short, the documentation for the “Find records” action claims that its output can be used in any later step, but in a recent discussion with another user, it was pointed out that Airtable support claims that it’s only designed for use with email action steps.

Anyway, like I said, it’s not actually needed. When a record triggers the automation, that record’s data is instantly available via the trigger step, so there’s no need to find it separately. Set up the “Update record” action to use the data from the record in the trigger step, and it should work smoothly.

2 Likes

Thank you, Justin! I spent some hours trying to solve the problem and reading the documentation.
I was just trying to classify my tasks according to the Eisenhower Matrix (using integrations with Todoist).

This is what I did: I used filters within the views, so I could avoid the “finding records” step. Now I have just two steps: when a record enters a view and updating record. It’s working just fine.

I was wondering if I could use “find record” as I intended, because I tried every possible combination and none of them worked. Now I know why: it’s not supposed to be used that way. Hahahaha!
Thank you for taking the time to answer. I am learning a lot from the community. :slight_smile:

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.