How do automations run when conditions match for all records?

Hi,
I have a synced table.
In the destination base/table I have created additionally a single select field => this should represent the status of the record.
Target: Change the created single choise, based on the condition that one of the synced fields has some specific text inside. => And this for each record.

I set up an automation:
Trigger:

  • When a record matches conditions
    –> when “Synced_Field_in_Table” contains “xyz”

Actions:

  • Update Record
    –> RecordID => Record ID from step 1:Trigger
    Fields:
  • “SingleChoiceField”
    Record(Step 1:Trigger)…Synced_Field_in_Table

=> Tests run successful & it did do it => But only for this one field.

Whereas I wanted it to do it for all records matching that conditions (& there are quite few more).

Is there a “loop” that can be triggered or something else I am missing.
I would like to make this automation go through all records.

Thanks in advance

Test run will only do it for one records so you can test is everything as you wanted.
It might be a stupid question, but did you actually turn your automation ON after you finished setting it up and ruining a test?

Hi Marko,
yes, it’s on (I wished it would be that easy).
But on the run-tab there is no run mentioned.
Any idea?

I am not an expert, so there might be another reason in your case, but i remember having a similar issue at one point. I came to conclusion that automation wont trigger on records that meet condition but those conditions where “fulfilled” before creation of automation. It will only “listen” to changes after you turn it on. I am not sure if this is always default behavior, but I think that might be the problem.

Maybe someone with more experience can confirm this, and maybe provide some workaround for this, if there are any :slight_smile:

3 Likes

@Marko.Petrovic: You’re right, that’s how it works.

@Onur: You may consider adding a temporary checkbox field, adding an additional condition to your trigger “when checkbox = true”, turning the automation back on, then checking all the records you want to run the automation for. Once that’s done revert your automation back and delete the checkbox field.

2 Likes

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.