iCal/Google Cal sync issue

My base has event dates and times listed, and I want the data to show up on Google Calendar.

However when I added it onto Google, all my events were listed with wrong times…

Although the iCal url Airtable provided for syncing stated my timezone, I noticed the calendar timezone was GMT 0. It seems to be the default and cannot be changed.

Some questions:

• Is there any way to overcome this timezone issue? It’s critical to have the event time listed in the calendar.

• Does my Airtable base need to specify a start and end time? Right now it only has a date and time.

Any help would be greatly appreciated!

The first thing to check is your Google Calendar settings, to make sure that it is set to display calendar events in your current time zone.

If that’s set properly, then go back into your date field in Airtable and customize it. At the bottom of the time format section, there is a toggle for GMT time. You will want to turn this off to make sure that the event time automatically adjusts to your local time zone.

Also note that Google Calendar only refreshes subscribed calendars every 24-48 hours. So to see the change take place in Google Calendar, you will need to unsubscribe from the calendar and then resubscribe to it again.

If you’re on a Mac, you can use a 3rd-party calendar client like BusyCal which refreshes your subscribed calendars on demand, or as quickly as every 5 minutes.

Hi Scott,

Yup I did everything you mentioned when setting up the calendar but it didn’t work. I also erased and entered the date and time fields on Airtable again, and then deleted and added the calendar in Google but it still didn’t work. Any idea why this is so and how I can fix it?

Thanks so much for your help!

Sorry, that’s all I’ve got! I would email support@airtable.com to see if they can help.

Ok I’ll give that a shot. Thank you!

Hi Gloria, I am having the same issue. Is this something you were able to easily fix with help of support?

Hi Lauren sorry I missed your message! It automatically fixed itself at first but later on got messed up because of daylight savings. Support gave me some workarounds but I’ve been too busy to test it out.

Here’s the primary suggestion:

In the meantime, you can add a formula field that uses a DATEADD to manually adjust your datetime to become the GMT equivalent (EST +4; PST +7) and use that for the ical link instead. (I realize it’s an inelegant solution, but hopefully it does the trick while we figure this out.

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.